Universal PACS Progress

I will take only the most minimal credit, but GE is addressing our Universal Viewer PACS issues. From a GE VIP:

(GE) has escalated your top 3 issues for assistance in resolution. I was out of the office last week, but will be meeting this afternoon with our Leadership Team for needs in our zone and I have added your site to the agenda. This will ensure that GE Leadership is fully aware of the need and issues at your site.

I have also forwarded the tickets to a manager of the Customer Center asking for a dedicated resource to be assigned to all of your open tickets that either you or the GE team have opened on your behalf. I expect to have this update this afternoon.

. . . I will work to remove any roadblocks to getting your issues reviewed and updates to you and your team as soon as possible.

The top red issues identified on your tracker that I will attack first are listed below, if any others are more critical or just as critical let me know so I can keep the appropriate focus on your most important issue resolutions first and then we will continue working through the list.

Pet Fusion Hanging protocols not displaying properly. SUV values are not reliable. Images not displaying correctly in g/ml.

Measurements not saving on Image.

CT Series slices dropping out.. Viewer on shows the message 0% Loaded.

Thank you and please reach out to me directly if you have any concerns.

I am very grateful for this response. I don’t expect immediate miracles, but this is progress, folks.

So far, though, much local effort has been directed toward figuring out why the timestamp on our notes reads one hour later than every system and workstation clock. I suggested that there might be some Time Zone setting buried in the PACS backend, but I don’t think my credibility is adequate to participate in the process.

A correction/addition…the UV PET/CT fusion does not work correctly. It was not DESIGNED correctly. Please see my previous post.

In the meantime, we are all very meticulously dictating all measurements and the number of the slice on which the lesion is found. I suppose that is good etiquette regardless of the annotation malfunction. And I may have a solution to the slice disappearance; I have found that if I don’t start scrolling until the entire display has loaded, in other words, when things stop moving, more often than not all slices are present and accounted for. I’m guessing there is some faulty code somewhere that allows the impatient radiologist to interrupt the loading of the scan data. I do believe IMPAX had a similar glitch years ago. Perhaps GE could buy Agfa, and create Universally Agile IMPAX, therein solving the problem. I can’t believe I just said that…

via Blogger http://ift.tt/1K0LLT3 May 30, 2015 at 09:50AM

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s